Latency on job offers updates
Incident Report for Welcome to the Jungle
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 09:04 CET
Update
We are continuing to monitor for any further issues.
Posted Mar 19, 2024 - 09:03 CET
Monitoring
The fix has been deployed and we are observing improved performance. New updates on jobs should be published on the job board normally and we are catching up on previous updates to reflect them on WTTJ as well.
We are monitoring the results.
Posted Mar 18, 2024 - 16:06 CET
Identified
We have identified the root cause of the latency and we are deploying a fix to address the issue.
Posted Mar 18, 2024 - 15:44 CET
Update
We are continuing to investigate this issue.
Posted Mar 18, 2024 - 15:38 CET
Investigating
We are observing a high latency when publishing or archiving jobs. Updates may take some time to be reflected on Welcome to the Jungle job board.

Our team is actively investigating this issue.
Posted Mar 18, 2024 - 14:25 CET
This incident affected: Welcome to the Jungle main website, Welcome to the Jungle Solutions ATS, and Welcome to the Jungle Solutions ATS - External APIs.